I have a free NetApp FAS2050, a very old Cisco 2950 100mb switch and a HP DL380 server. Can I make them work together?
My objective is to run ESXi 5.1 on the HP server with two guests (an Exchange 2010 server and a domain controller). The server only has 2 NICs unfortunately: one of them will be used for iSCSI and the other management. The NetApp must be configured in one big RAID 10 volume. They must communicate through the 2950.
The Cisco 2950
Log in as a super user:
en ↵
[password] ↵
The "show" command followed by "?" will display all the informational commands. To start off, good informational commands:
show running-config ↵
show interface status ↵
The switch that I picked up has most of its ports set to VLan 100, but I want VLan 302 because that is what the NetApp is set to. To create a VLan:
conf t ↵
vlan 302 ↵
name iSCSi ↵
Ctrl Z
Now to assign a port (or two) to the previously created VLan:
conf t ↵
int fa0/1 ↵
switchport mode access ↵
switchport access vlan 302 ↵
Ctrl Z
If you wanted to make that port a trunk you would have entered:
switchport mode trunk ↵
A trunk can accept multiple VLan traffic:
switchport trunk allowed vlan 100,302,303
I cheated a bit in the end. I had the config from the switch the NetApp used to be plugged into. From that I determined how the ports should be configured. This is the port configuration that I copied:
interface GigabitEthernet0/7
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,302,303
switchport mode trunk
spanning-tree portfast
After this the NetApp could be pinged and I could connect to it via putty.
My objective is to run ESXi 5.1 on the HP server with two guests (an Exchange 2010 server and a domain controller). The server only has 2 NICs unfortunately: one of them will be used for iSCSI and the other management. The NetApp must be configured in one big RAID 10 volume. They must communicate through the 2950.
The Cisco 2950
Log in as a super user:
en ↵
[password] ↵
The "show" command followed by "?" will display all the informational commands. To start off, good informational commands:
show running-config ↵
show interface status ↵
The switch that I picked up has most of its ports set to VLan 100, but I want VLan 302 because that is what the NetApp is set to. To create a VLan:
conf t ↵
vlan 302 ↵
name iSCSi ↵
Ctrl Z
Now to assign a port (or two) to the previously created VLan:
conf t ↵
int fa0/1 ↵
switchport mode access ↵
switchport access vlan 302 ↵
Ctrl Z
If you wanted to make that port a trunk you would have entered:
switchport mode trunk ↵
A trunk can accept multiple VLan traffic:
switchport trunk allowed vlan 100,302,303
I cheated a bit in the end. I had the config from the switch the NetApp used to be plugged into. From that I determined how the ports should be configured. This is the port configuration that I copied:
interface GigabitEthernet0/7
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100,302,303
switchport mode trunk
spanning-tree portfast
After this the NetApp could be pinged and I could connect to it via putty.
No comments:
Post a Comment